Claude.ai is currently unavailable

Incident Report for Champlain College

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 14:11 EST

Monitoring

A fix has been implemented and Anthropic is monitoring the results.
Posted Dec 02, 2025 - 13:02 EST

Investigating

Anthropic is investigating the issue. Updates can be found on their status page: status.anthropic.com
Posted Dec 02, 2025 - 12:05 EST