Canvas LMS Outage

Incident Report for Champlain College

Resolved

Canvas has identified the issues and corrected them. Canvas is now available.
Posted May 07, 2026 - 20:45 EDT

Investigating

Canvas is currently unavailable and we are awaiting further information from Instructure. Please follow status.instructure.com for updates.
Posted May 07, 2026 - 17:01 EDT
This incident affected: Canvas (Canvas LMS - Champlain.Instructure.Com).